Using a Macromedia Flash MX quiz template

Overview

Macromedia Flash MX quiz templates offer a streamlined process for developing e-learning
systems that can send tracking data to a web sever-side learning management system (LMS). The
templates are compliant with Aviation Industry Computer-Based Training Committee (AICC)
protocol and Shareable Content Object Reference Model (SCORM) standards.

For AICC or SCORM tracking, your Windows users must have Internet Explorer 4.0 or
Netscape Navigator 4.0 or higher. Macintosh users must have Netscape 4.5 or higher. Tracking to
a LMS will not work with Internet Explorer on the Macintosh.

The quiz template that you'll use in this tutorial includes six different types of interactions
(including Multiple Choice, Drag and Drop, and Hot Spot). The last frame in the template uses
cumulative data to display quiz results. Additionally, the quiz templates in Macromedia Flash MX
already include the necessary ActionScript and navigation controls, allowing you to focus less on
development and more on tailoring the quiz content to meet your learning objectives.

What you should know

Although this tutorial is designed for beginning Macromedia Flash users, you should be familiar
with basic Macromedia Flash concepts such as those presented in the learning media that ship
with Macromedia Flash MX. To access the lessons, open Macromedia Flash and choose Help >
Lessons. The introductory tutorial is available by choosing Help > Tutorials and selecting
Introduction to Flash MX. Additionally, because the quiz templates rely on use of components,
you'll find it helpful to read the Using Components topics in Macromedia Flash MX Help.

For comprehensive information about Macromedia Flash MX quiz templates and stand alone
learning interactions, refer to Using Macromedia Flash MX learning interactions at hetp://
www.macromedia.com/support/flash/applications/learning_interactions/.




What you’ll learn

This tutorial demonstrates how to modify Macromedia Flash MX quiz templates to create a
movie that uses six different types of learning interactions. The tutorial takes approximately

1 1/2 hours to complete, depending on your experience, and will teach you how to accomplish
the following tasks in designing a quiz:

® Analyze the quiz template and learning interactions
® Specify LMS tracking
® Add custom graphics and components

® Modify True and False, Fill in the Blank, Multiple Choice, Drag and Drop, Hot Object, and

Hot Spot interactions
® Add an interaction to the Timeline

® DPublish the movie to conform to AICC tracking

Open a new document from a quiz template

Macromedia Flash MX includes three templates that each have a distinct graphical format,
although the quiz functionality is identical.

1 Open Macromedia Flash MX and choose File > New from Template.
2 In the New Document dialog box, select Quiz as the category.
A preview of a quiz template appears in the dialog box.
3 In Category Items, select each of the three quizzes, one after the other, to preview the templates.

4 Select Quiz_stylel and click Create.
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5 Choose File > Save As, and name the document MyQuiz.fla. (Consider creating a new folder
in which to save the document, because the publish process generates additional files saved in
the same location as the FLA file.) After selecting a location in which to save the file, click Save.

Note: Throughout the tutorial, remember to test and save your work frequently.




Take a tour of the quiz template
The quiz FLA file includes the following layers:

A hidden Instructions layer that explains how to use the template. You can show the
Instructions layer and click each of the 8 frames in the document to view steps on using the
template, then hide the layer. The Instructions layer is a guide, which is not included in your

published movie.
A Title layer, which includes title text designed to appear on every frame in the document.

An Interactions layer, which includes components for 6 different types of interactions on
Frames 2 through 7. These interactions include True or False, Fill in the Blank, Multiple
Choice, Drag and Drop, Hot Object, and Hot Spot.

A _controls layer, which holds the Quiz component that you can modify.
A _bckgrnd layer containing objects included in all frames of the template.

An _actions layer that contains simple ActionScript to make the playhead stop at each frame.

Analyze the Quiz component

Frames 1 through 7 in the Quiz template include the Quiz component, which lets you set
parameters that determine how to present the quiz to users.

1
2

Click Frame 1 of the Interactions layer.

To view the entire Welcome page and Quiz component, select Show All from the Stage View
pop-up menu.

Click the Quiz component, to the left of the Stage. In the Property inspector, click Launch
Component Parameters Panel.

If the text in the Component Parameters panel is too small to be legible, drag a corner of the
panel to enlarge it.

w Component Parameters
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Although you will not change any of the default settings on the Component Parameters panel,
view the options that the panel lets you specify:

® Randomize, if selected, specifies that questions appear to the user in random order, not
necessarily in the order in which they appear across the Timeline.

® Questions to ask, if set to 0, presents the user with all questions included in the quiz. You can
also set the number to be less than the number of questions in the quiz. If you specify a number
less than the total number and select Randomize, each launch of the quiz presents a subset of
the total number of questions, in random order. If you specify a number larger than the number
of questions in the quiz, the quiz presents all of the questions without duplicating them.

® The Login File URL redirects users to the specified URL to login if the user has not logged in
through an AICC-compliant LMS.

Note: If the user does login through an AICC-compliant LMS, but the HTML parameters that launch the movie
do not exist, the login file URL redirects users to the specified URL.

® Activity ID and Activity Name fields correspond to the activity name and Activity ID in your LMS.
If you're not using a LMS, you can either accept the default entries, or the fields can be blank.

® The Show Results Page option, if selected, displays the quiz results on Frame 8 of the quiz
template to users upon completion of the quiz.

5 When you finish viewing the Component Parameters panel, close it.

Analyze a learning interaction

Learning interactions immerse users in e-learning content by requiring active participation. The
interactions included in Macromedia Flash MX offer you the choice of using several types of
interactions in a movie.

1 In the Timeline, select Frame 3 of the Interactions layer.

The Stage includes dynamic text fields, and one input text field, all grouped within the fill in
the blank interaction movie clip. During run time, the text that you specify in the Component
Parameters panel for the interaction populates the dynamic text fields.

2 Ifthe Library panel is not open, choose Window > Library and expand the panel, if necessary.
Expand the 2_Learning Interactions folder to view the six interactions included in the template.

3 Click any of the six interactions, such as Drag and Drop, to see in preview that the interaction
is really a set of objects, such as movie clips, graphics, and components, grouped together.

To use a learning interaction, you break it apart, then modify the individual objects that
comprised the group.

4 When you finish viewing the interactions, close the Library panel.

Note: You can add stand alone learning interactions to any Macromedia Flash MX document, even if you're not
using the quiz template. To access these interactions outside of the template, choose Window > Common Libraries >
Learning Interactions. Stand alone interactions, when used in Macromedia Flash documents outside of the quiz
template, are not designed for use with SCORM tracking.




Test the quiz template
The quiz template is designed for you to test it immediately, to see how the interactions perform.
1 Choose Control > Test Movie.
2 View the text and navigation on the Welcome page, then click the next button along the
lower-right edge of the movie.
Answer a true or false interaction

On the True or False question, as with all interactions in the quiz, the Check Answer button is
not active until you select a response. The feedback text instructs you to click a radio button.

1 Select either True or False, and watch the feedback text change. Click Check Answer.

The feedback text now indicates whether or not you answered the question correctly, and the
check answer button is now inactive.

3 MyQuiz swf M= B
Practice Quiz
A predator of the Hooded Warbler is the Neotropical Green
Frog.
@ A True
@ B. False
Check Answer | Yesthatis corect. 277 D)

2 Click the Next button.

Answer a fill in the blank interaction

The fill in the blank interaction lets you type a response in an input text field. When you click
Check Answer, the template checks the response against matching phrases specified in the

template. You can configure the component parameters to accept phrases that are either a close
match or an exact match.

* Type your answer to the fill in the blank interaction, and click Check Answer. After viewing
the response, click Next.
Answer a multiple choice interaction
The multiple choice interaction lets you answer a question by selecting one or more responses.

1 Click one or more checkboxes to answer the question, then click Check Answer.
2 View the feedback and click Next.
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Drag and drop objects on to targets

The Drag and Drop interaction lets you respond to a question by dragging objects, which are
usually graphical, that you add to the template, to corresponding targets. For example, the
question might ask users to drag a painting to the artist who created it, or arrange a sequence of
objects in a certain order.

1 Drag the numbered “drag” squares close to either a corresponding numbered or incorrect
target, then release the mouse to see the object snap to the target. When you've placed all four
drag objects, click Reset.

Reset is a helpful feature for users who complete part of the interaction, then realize they want
to respond differently.

2 Drag the objects to targets again and click Check Answer.

3 View the response and click Next.

Select a hot object

The Hot Object interaction lets you respond to a question by clicking one or more objects to select
them. You can think of a Hot Object interaction as a graphical version of a multiple choice question.

The Hot Object interaction is designed for you to add graphics to the template. Object 4 is
specified as the correct object in the component parameters.

1 Click object 4, to see how the interaction offers visual feedback when an object is clicked. A red
tint appears over the clicked object.

2 Click Check Answer. View the response and click Next.

Select a hot spot

The Hot Spot interaction lets users respond by clicking a region on the Stage. For example, you'll
use the Hot Spot interaction in this tutorial to have users click the part of the camera that allows
you to take a picture. You'll add an image of a camera to the Stage, and configure the interaction
so that the user can click a variety of camera parts, with the shutter release specified as the correct
part to click.

1 Click one of the numbered areas on the Stage, then click Check Answer.

2 View the response and click Next.




View the quiz results

The quiz template is designed to automatically track results and send them to a learning
management system configured for your quiz.

3 MyQuiz swf M= B

Practice Quiz ,

Quiz Results

Total Correct: 6
Total Incorrect: 0

Total Score: ~ 100%

® When you finish viewing the quiz results, close the SWF movie.

View a completed version of the quiz tutorial file
Now you'll view a completed version of the file you’ll create from the quiz template.

1 In Macromedia Flash MX, choose File > Open. Browse to the QuizTutorial folder that you
downloaded and double-click learning.fla to open the quiz in the authoring environment.

2 Choose Control > Test Movie. Take the quiz to see how the designer modified the template. When
you finish taking the quiz, close the SWF window and learning.fla, and return to MyQuiz.fla.

4
Click the next button o continue.
]
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Modify the Welcome page

You'll delete the existing background, and replace it with a gradient background. You'll then add
and modify text, and use an external library to add assets to the document.

1 In the Timeline, hide the Instructions layer if it’s not already hidden.
2 Lock all layers except the _bckgrnd layer, and select Frame 1 of that layer.

3 On the Stage, verify that the background is selected (a bounding box appears around the Stage)
and press Backspace or Delete.

Create a gradient background

A gradient displays subtle variations of a color, or transitions between two or more colors. You'll
create a gradient that blends white and blue.

Draw a rectangle
You'll now draw a simple rectangle as the first step in creating a gradient background.

1 In the toolbox, select the Rectangle tool.

2 In the toolbox, click the Stroke Color control. Select No Stroke (the button with the red
diagonal line above the color palette).

The selected fill color of the shape is unimportant; you'll soon change the color.

3 Starting from the upper left corner of the Stage, drag to the lower right corner of the Stage to
draw a rectangle that covers the Stage.

Note: While completing the tutorial, you may find it useful to undo a change you’ve made. Macromedia Flash can
undo several of your recent changes, depending on the number of undo levels you have set in Preferences. To undo,
choose Edit > Undo or press Control+Z (Windows) or Command+Z (Macintosh). Conversely, you can redo what
you’ve undone by choosing Edit > Redo or pressing Control+Y (Windows) or Command+Y (Macintosh).




Specify a color for the gradient

White is the first color you'll add to your gradient.

1
2
3

In the toolbox, select the Pointer tool. On the Stage, click inside the rectangle to select the fill.
If the Color Mixer is not open, choose Window > Color Mixer.

To expand the Color Mixer, click the white arrow in the panel title bar. If the Color Mixer is
not fully expanded, click the arrow in the lower right of the panel.

In the Fill Style pop-up menu, select Radial.

If the gradient slider to the left of the color bar is not selected, with a small triangle above it, click it.
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Click the color box in the upper left corner of the window to open the color palette. Use one of
the following methods to select white:

Move the eyedropper over the color swatches until you find white with the hexadecimal value
of FFFFFE then click the swatch to select it.

Type FFFFFF in the hexadecimal value text box and press Enter or Return.

Add a second gradient color

You'll now add blue to the gradient.

1

In the Color Mixer, click the gradient slider to the right of the gradient bar to select it.

2 Click the color box to open the color palette and select the blue with a hexadecimal value

of 003366.

Remember, you can either type the hexadecimal value in the Hexadecimal text box and press
Enter or Return, or you can find and select the color swatch with the same hexadecimal value.
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3 In the toolbox, select the Fill Transform tool. On the Stage, click anywhere inside the rectangle.

An ellipse that indicates the shape and location of the gradient appears around the Stage (resize
the Stage view, as necessary). The ellipse has controls for the location, width, scale, and

rotation of the radial gradient.
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4 Drag the circular middle handle, which controls the size of the gradient, to the right to make
the ellipse larger, spreading out the lighter area of the gradient.

Welcome

Click the next buttey to continue.

-
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5 Drag the gradient center control toward the lower right side of the Stage.

I|

/

6 Lock the _bckgrnd layer.

Modify and align text

You can modify text in the template to specify attributes.

1

In the Timeline, unlock the Title layer. With the Pointer tool, select and delete the text field on
the stage that contains the words Practice Quiz. Lock the Title layer.

Unlock the Interactions layer and select Frame 1 of the layer.

In the toolbox, select the Pointer tool. On the Stage, double-click the Welcome text. Drag to
select the Welcome text and use the Property inspector to set the text as 16 point, Arial, bold.

Select the Welcome text again and type Introduction to Photography.

Select the Pointer tool and use the Property inspector to give the Introduction to Photography
text X and Y coordinates of 10.7 and 14.5, respectively.

Select the Text tool and click the Stage underneath the first text field to create another text
field. Use the Property inspector to set the field to Arial 12 point bold. Type The World of
35mm Photography Quiz.

Use the Pointer tool to select the new text field, and use the Property inspector to give the text
Xand Y coordinates of 9.7 and 34.5, respectively.
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8 In the toolbox, select the Line tool and select Black as the stroke color. In the Property
Inspector, verify that 1 is selected for the stroke height, and Solid is selected for the stroke style.

9 To constrain the line, hold Shift and draw a horizontal line from the lower right edge of the
title text, after the word Photography, to end slightly before the edge of the Stage.

10 With the Pointer tool, select the text that states Click the next button to continue. Use the
Property inspector to give the text an X coordinate of 333.4 and a Y coordinate of 339.9.

Use assets from a shared library

The assets that you'll use in your document exist in a separate FLA file, which you will open as a
library. Assets that you use from the external library become part of the MyQuiz.fla library. You'll
now replace the navigation button with a different navigation button, which has the same name,
from the LearningAssets library.

1 In the Timeline, unlock the _controls layer and select Frame 1 of that layer.
2 Choose File > Open as Library.

3 In the Open as Library dialog box, browse to your QuizTutorial folder. Select
LearningAssets.fla, then click Open.

The library items from the LearningAssets.fla file are now available for your use.

w Library - LearningAszsets. fla
156 items

[ 1_QuizFiles
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4 In the LearningAssets.fla library, go to the 1_Quiz Files > 0_Assets sub folder and drag mc,
frameNav to anywhere on the Stage or on the work area.

A Resolve Library Conflict dialog box appears because you dragged an instance of a symbol
that already exists in your MyQuiz library.

5 In the Resolve Library Conflict dialog box, select Replace existing items (not undoable)
and click OK.

i

In addition to dragging a new instance of the button on to the Stage, you've replaced the
original mc, frameNav button with the new version.

Note: You can also drag symbols directly from one library to another.
6 On the Stage, select the button that you just dragged to the Stage and press Backspace or Delete.

You do not need the second instance on the Stage once the first instance, in the lower-right
corner of the Stage, is replaced.

7 With the Pointer tool, select the mc, frameNav button and use the Property inspector to give it
an X coordinate of 464.6 and a Y coordinate of 369.4.

8 Select Frame 1 of the Interactions layer. Drag Cameral.png from the Images folder in the
LearningAssets library to the Stage, placing the camera slightly off center, within the light area
of the gradient background.
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Modify a True or False interaction

Each interaction has a component that you modify in the Component Parameters panel.

To modify the True or False component, you'll add the question text and specify if the statement
is true or false.

1 In the Timeline, select Frame 2 of the Interactions layer.

2 On the Stage, verify that the True or False component, as well as the grouped Stage objects, are
selected. (A bounding box surrounds the objects.)
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3 Choose Modify > Break Apart.
Bounding boxes appear around individual objects on the layer.

Note: Throughout the tutorial, you will break apart the learning interactions to modify the template. Be careful
to use the break apart command once only, with each interaction. If you choose Break Apart a second time for
an interaction, the interaction becomes unusable and you must replace it with the stand-alone interaction from
the library.

4 Deselect all selected objects by pressing Control+Shift+A or clicking an empty space in the
work area.

5 To the left of the Stage, select the True or False component. In the Property inspector, click
Launch Component Parameters Panel.

6 Select the text in the Question text box and type The higher the aperture setting, the more
light passes through the lens.

Note: The question text appears in the dynamic text field on the Stage during runtime; you do not type question
text on the Stage.
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7 Select the False distractor (choice).

Interaction ID  |Interaction_01 |

Question

The higher the aperture setting, the mare light passes
through the lens.

Distractors Carract
| A True O
| B. False (o)

8 Click Options, along the bottom of the panel, and change the Feedback text:

® Initial feedback is the text the user sees in the Template_Feedback dynamic text field before
answering the interaction. For the Initial Feedback text box, select the existing text and type
Click a radio button.

® The correct feedback is the text the user sees after answering the question correctly and clicking
Check Answer. For Correct feedback, select the existing text and type Correct!

® Incorrect feedback is the text the user sees after answering a question incorrectly and clicking
Check Answer. Select the existing text in the Incorrect Feedback text box and type Sorry. Your
answer is incorrect.

9 Verify that Off is selected for Navigation, and close the Component Parameters panel.

Because the template has its own built-in navigation, you do not specify navigation in the
Component Parameters panel.

The Knowledge Track options are for use with your LMS.

Note: You will use the Component Parameters panel for each interaction. You can either close the panel after
configuring the parameters, or move it out of the way until you’re ready to use it again.
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Modify text and add a graphic to the true or false question

With the True and False interaction, you'll move both the question text and the checkbox
components.

1

In the Timeline, verify that Frame 2 of the Interactions layer is still selected. Use the Pointer
tool to select the Your question will appear here text. Use the Property inspector to make the
text Arial 14 point bold, with an X coordinate of 10.7 and a Y coordinate of 14.5.

With the Pointer tool, select the True component on the Stage. Give it an X coordinate of 11.7
and a Y coordinate of 49.5.

3 Select the False component on the Stage and place it so that X = 11.7 and Y = 70.8.

In the LearningAssets.fla library, drag lens.png from the Images folder toward the center of the
Stage, where the background gradient is lightest.

s,
Control Button

Note: As you complete the tutorial, remember to save and test your work frequently. Testing is especially important
when modifying learning interactions to ensure your quiz works as expected.

Modify a Fill in the Blank interaction

To modify the Fill in the Blank component part of the interaction, you specify the question text,
then specify all answers that are acceptable as correct.

1
2
3

In the Timeline, select Frame 3 of the Interactions layer.
On the Stage, verify the objects on the layer are selected. Choose Modify > Break Apart.

Deselect all selected objects by pressing Control+Shift+A or clicking an empty space in the
work area.

To the left of the Stage, select the Fill in the Blank component. If necessary, launch the
Component Parameters panel from the Property inspector.

Select the text in the Question text box and type What does the number 125 on the
camera indicate?
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6 In the first Responses text box, type Shutter speed, and select the Correct check box.
7 Verify that Case Sensitive is not selected and Exact Match is selected.

8 Click Options, along the bottom of the panel. To give the user two chances to answer the
question correctly, type 2 in the Tries text box.

When you give the user more than one chance to answer the question correctly, feedback
specified in the Additional Tries text box appears if the user first answers incorrectly.

9 Select the text in the Additional Tries text box and type Incorrect. Please try again.

10 Change the text in the other feedback text boxes, as desired. For example, you can select the
text in the Correct Feedback text box and type Yes! You're right!

Fill In The Blank

Additional Tries

Options

v Feedback Tries [2 |
Initial Feedback Fill in the hlank Text Field. |
Correct Feedback ves! vou're Hohtl] |
Incorrect Feedback Mo that is incorrect. |
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Weighting 1 |
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GoTo Action @® Stop O Play
GoTo Label |

Interaction Options Assets

Arrange text and graphics

To give the interaction a consistent look, you’ll modify the text fields, move the graphic
representation of the input text field, and add an image to the interaction.

1 With Frame 3 of the Interactions layer selected, Use the Pointer tool to select the Your
Question Will Appear Here text. As you did with the previous interaction, make the text
14 point Arial bold. Give the text an X coordinate of 10.7 and a Y coordinate of 14.5.
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2 On the Stage, select the instance of Field_Background, with the text that states Enter your
answer here, and place it so that X = 11.1 and Y = 45.1.

Drag input text field to
this location

Input text field

Cortrol Bution

3 The actual input text field appears on Stage bounded by dotted lines. Drag the input field
within Field_Background instance.

4 In the LearningAssets.fla library, drag Camera_top.png from the Images folder to the Stage.
Place the image below the input text field.

5 In the LearningAssets.fla library, drag 125_glow.png from the images folder to the Stage. Place
the image over 125 on the camera’s shutter speed selector.

Note: As you complete the tutorial, remember to test and save your work frequently.
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Modify a Multiple Choice interaction

To modify the Multiple Choice component, you'll add the question text, the answer text, and
specify which answer is correct.

1 In the Timeline, select Frame 4 of the Interactions layer. On the Stage, verify that objects on
the layer are selected, and choose Modify > Break Apart. Press Control+Shift+A or click an
empty space in the work area.

2 Select the Multiple Choice component. If the Component Parameters Panel isn't open, launch
it from the Property Inspector.

3 Select the text in the Question text box and type Which camera part affects the amount of
light that passes through the lens?

4 In the Label text box for Checkbox 1, select Apple and type Shutter speed. Click the check

mark in the Correct column to indicate that the choice is now an incorrect answer.

5 In the Label text box for Checkbox 2, select Zucchini and type Film advance lever. Do not
click the check mark in the Correct column.

6 In the Label text box for Checkbox 3, select Tomato and type Aperture, and verify that the
corresponding Correct check box is selected to indicate that this is a correct answer.

7 In the Label text box for Checkbox 4, select Potato and type Film counter. Do not click the
check mark in the Correct column.

8 You will have four choices, instead of the five that the template provides. To delete the last
choice, select Checkbox 5 in the Instance Name category and press Delete or Backspace.

+ Component Parameters

Multiple Choice

=

Interaction ID  [interaction 01 |
Question

Which camera part affects the amount of light that
passes through the lens?

Instance Name  Label Text Correct
Checkbox! || A Shutter speed ']
Checkhox2 | B. Film advance lever | D
Checkbox3 | C. Anerture v
Checkboxd || D. Film counter ]
| | O

| O

Cl

0l

Interaction Options Assets

9 If desired, click Options and change the correct and incorrect feedback text. The user will have
one try to answer the question correctly; you do not need to change the additional tries
feedback text since that text will not appear to the user.
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Arrange text and graphics

You'll modify the question text, delete one of the answers, and add an image to the interaction.

1 On the Stage, use the Pointer tool to select the Your Question Will Appear Here text. Use the
Property Inspector to make the text Arial 14 point bold, with X and Y coordinates of 10.7 and
14.5, respectively.

2 Select and delete the instance of Checkbox5 (Label E).

3 Select the Label A component (Checkbox1). Press Shift and click the Label B through D
objects to add them to the selection. In the Property inspector, select the text in the Width (W)
text box and type 160 to resize the choice labels, then press Tab.

4 Drag the four selected labels to just below the question text.

5 In the LearningAssets.fla library, drag Camera2.png from the Images folder to the Stage,
placing the image slightly to the right of the four choice labels.

Control Button
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About graphic distractors

The Drag and Drop, Hot Object, and Hot Spot interactions use placeholder instances. To change
the appearance of the interaction, you can either delete the existing instances and register new
instances or you can replace or modify the symbols.

If you'll use a graphic interaction more than once in the Timeline, or if you don’t want to change
the interaction movie clip that exists in the library, you must follow a process that deletes the
existing instances and names and registers instances of new movie clips. The original interaction
remains unchanged in the Library, and available for use again. In the tutorial, you'll follow this
process with the Drag and Drop interaction.

If you know that you will not use the same type of graphic interaction more than once in your
movie, you can replace the existing movie clips with movie clips that have exactly the same name.
The interaction reflects the changes and updated art. In the tutorial, you'll follow this process
with the Hot Object interaction.

You can also edit the movie clip symbol. You'll follow this process for the Hot Spot interaction.

Modify a Drag and Drop interaction

The Drag and Drop interaction lets users drag objects to targets. The component lets you specify
the question and the unique names of the drag objects and targets.

1 In the Timeline, select Frame 5 of the Interactions layer.

2 On the Stage, verify that objects on the layer are selected, and choose Modify > Break Apart.
Press Control+Shift+A or click an empty space in the work area to deselect the objects.

3 On the Stage, select Dragl, then press Shift and also select Drag2 through 4, and Targetl
through 4. Press Backspace or Delete to delete all drag and target objects from the Stage.

4 Select the Drag and Drop component to the left of the Stage. If the Component Parameters
Panel isn’t open, launch it from the Property inspector.

5 Select the text in the Question text box and type Drag the photo to the correct exposure setting.

6 In the Drag Object Name and Matches Target Name categories, select and delete the Drag4
and Target4 text; your quiz will have three Drag objects and three Target objects only.
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7 In the Drag Object Name and Matches Target Name categories, type the letter N, for new, at
the end of each name.

You're registering the unique instance name that you will give to your replacement instances.

w Component Parameters =

Drag and Drop

Interaction ID |Interacti0n_D1 |

Question
Drag the photo to the correct exposure setting.

Drag Object Name Matches Target Name
[Dragtn ||Target 1
|Dragzn |[Target2n
|Drag3N ||Target3N

|

|

|

|

Snap To Start
Interaction Options Assets

8 To specify that drag objects snap to a target, verify that Snap To Start is selected.

Arrange text
You'll give the question text the same attributes that you specified in previous frames.

® On the Stage, use the Pointer tool to select the question text. Use the Property inspector to
make the text Arial 14 point bold, with X and Y coordinates of 10.7 and 14. 5, respectively.
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Assign instance names to the new drag symbols

You'll place the new “drag” symbols in the LearningAssets library, and give them the same
instance names in the Property inspector that you specified in the Component Parameters panel.

1 From the LearningAssets library, go to 2_Learning Interactions > 0_Assets > DragDrop folder,
and drag DD_D3 toward the upper left area of the Stage, as shown in the following illustration.

2 Place DD_D1 next to it, then DD_D2 at the end of the row.

3 On the Stage, select DD_3. In the Property inspector, enter Drag3N in the Instance Name
text box.

4 On the Stage, select DD_1. Use the Property inspector to give it the instance name of
DraglN.

5 On the Stage, select DD_2. Use the Property inspector to give it the instance name of
Drag2N.
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Assign instance names to the new target symbols

You'll follow a process similar to the one you just used for the drag symbols, to now drag the new
target symbols from the LearningAssets library, and give them the same instance names in the
Property inspector that you specified in the Component Parameters panel.

1 From the LearningAssets library, go to 2_Learning Interactions > 0_Assets > DragDrop folder,
and drag DD_T'1 toward the lower left area of the Stage, as shown in the following illustration.

3 On the Stage, select DD_T'. In the Property inspector, select the text in the Instance Name
text box and type Target1N.

4 On the Stage, select DD_T?2. Use the Property inspector to give it the instance name of
Target2N.

5 On the Stage, select DD_T3. Use the Property inspector to give it the instance name of
Target3N.
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Align Drag objects and Target objects

To align the Drag objects and Target objects, you'll use the Align panel.

1

On the Stage, with the Pointer tool, click DD_D3, then Shift+click to also select DD_D1
and DD_D2.

If the Align panel isnt open, choose Window > Align.

Verify that To Stage is not selected and click Align Vertical Center and Distribute Horizontal
Center. Press Control+Shift+A or click an empty space in the work area.

On the Stage, click DD_TT1, then Shift+click to also select DD_T2 and DD_T?3. Click Align
Vertical Center and Distribute Horizontal Center.

View the Drag and Drop movie clip in the Library window

In the MyQuiz (not LearningAssets) library, select the Drag and Drop movie clip in the
2_Learning Interactions folder.

The symbols remain unchanged; you can use the interaction again, if desired.

Modify a Hot Object interaction

To modify the Hot Object interaction, you first modify the component to specify the question
text, and you specify the object that will register as a correct choice when clicked.

1
2

In the Timeline, select Frame 6 of the Interactions layer.

On the Stage, verify that all objects on the layer are selected and choose Modify > Break Apart.
Deselect all selected objects by pressing Control+Shift+A or clicking an empty space in the
work area.

Select the Hot Object component. If the Component Parameters panel isn’t open, launch it
from the Property inspector.

Select the text in the Question text box and type Click the part of the camera you would press
to take a picture.

Select Correct for HotObject1 and deselect Correct for HotObject4.

When users click the HotObjectl area, the response will register as correct.
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Arrange text

You'll give the question text the same attributes that you specified with previous interactions.

® On the Stage, use the Pointer tool to select the question text. Use the Property inspector to
make the text Arial 14 point bold, with X and Y coordinates of 10.7 and 14. 5, respectively.

Replace hot object images

Although you can use the same process that you used with the Drag and Drop interaction, to
delete and register instances, you'll use a different process for the Hot Object interaction. Instead,
you will replace existing movie clips with new ones that have the same name. Because this process
changes all instances of the symbols, it works best when you know you’ll only use the interaction
type once in a document.

1 In the LearningAssets library, drag HO_Object1 from the 2_Learning Interactions > 0_Assets >
HotObjects folder to any place on Stage or in the work area.

HO_ODbjectl has the same name as a symbol that already exists in the template (MyQuiz) library.

2 In the Resolve Library Conflict, select Replace existing items (not undoable) and click OK.

The original movie clip reflects the replacement, and the instance that you dragged on to the
Stage is still selected.

(24

Press Delete or Backspace to delete just the instance that you dragged on to the Stage.

-

In the LearningAssets library, drag HO_ODbject2 from the 2_Learning Interactions >
0_Assets >HotObjects folder to anyplace on Stage or in the work area.

(3]

In the Resolve Library Conflict, select Replace existing items (not undoable) and click OK.

(=]

Press Delete or Backspace to delete just the instance that you dragged on to the Stage.

~

Follow the same previous steps 4 through 6 to use assets in the LearningAssets library (in the
2_Learning Interactions > 0_Assets >Hot Objects folder) to drag HO_Object3, HO_Object4,
HO_Object5 and HO_Object6 to the Stage, then delete the instance that you just dragged.
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View the Hot Object interaction in the Library window

In the MyQuiz (not LearningAssets) library, select the Hot Objects movie clip in the Learning
Interactions folder.

With the Drag and Drop interaction, the symbols did not change. The process that you used
for the Hot Object interaction replaces the symbols in the library.

To follow the process you used for replacing hot object movie clips, remember that you must
create movie clip symbols, in a separate FLA file, that have the same name as the movie clip
symbols that you want to replace. You can then open the separate FLA file as a library. You can
drag the instance of the new symbol to the Stage to replace the original symbol. You then delete
the instance that you just dragged. You can also simply drag the new symbol to the library where
you will replace the original symbol.

Change the color of a selected hot object

When the user selects a hot object, the object, by default, changes to light red to let the user know
that the object is clicked. You can change the default color in the Actions panel. You'll change the
“clicked” color from red to blue.

1

4

In your MyQuiz library, go to 2_Learning Interactions > 2_Components, and double click
2_HotObjects to enter editing mode.

In the 02_HotObjects Timeline, click Frame 1 of the Actions layer and open the Actions panel
(Window > Actions).

If you're not in Normal mode, click the Options menu on the right side of the title bar and
select Normal Mode.

Open the Options menu again and select Go to Line. In the dialog box, type 42 and click OK.

Note: For the correct line to be selected, you must not have auto format options selected for the Actions panel. If the
transform.rb line of ActionScript is not selected, choose Auto Format Options from the Options menu on the Actions
panel, and deselect any selected options.

This section of ActionScript lets you select red, green, and blue values for the color object. While
you can experiment with the value numbers to specify a color, we've already come up with values
that create blue, for you. For more information about what each line of code controls, search for
topics on the Color Object and the setTransform Object in Using Flash MX.

In the Value text box, enter 0.
If the Expert Mode Warning dialog box appears, click OK,

Select line 44 and enter 51 in the Value text box.
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7 Select line 46 and enter 102 in the Value text box, then close the Actions panel.

+ Actions - Frame =
| o] ictions for Frame 1 of Lager hlame fictions e
Actions - & =
Operators Vatisble: |mn;rmm bb ™ Expression
Functions walue: [102 ¥ Egpression
Canstants
Properties
[@]) Obieets o
Deprecated +-P2Rd 20 iE v .
Flazh Ul Components 4z transform.rb = 0: =
[E) Muli-Tracking Actions a3 transform.ga = 100
% :::: H a1 transform.gh = 51; —
- 45 transform.ba = 100
@ i 46 transform.bb = 102;
@ Mouie 47 transform.as = 20;
@ mouie 48 transform.ab = 255
[ ncex 45 restore = new Object () ;
50 restore.ra = 100:
51 restore.rh = 0;
52 restore.ga = 100; _';|
| |4l | »

8 Choose Edit > Edit Document.

Note: As you complete the tutorial, remember to test and save your work frequently.

Modify a Hot Spot interaction

To modify the Hot Spot component, you type the hot spot question, then specify which hot spot
area, when clicked, will register as a correct response.

1 In the Timeline, select Frame 7 of the Interactions layer. On the Stage, verify that all objects on
the layer are selected, and choose Modify > Break Apart, then press Control+Shift+A or click
an empty space in the work area.

2 Select the Hot Spot component. If the Component Parameters panel isn’t open, launch it from
the Property inspector.

3 Select the text in the Question text box and type Click the part of the camera that
advances the film.

4 Select Correct for HotSpot6 and deselect correct for HotSpot4.
A user click on HotSpot6 will now register as a correct answer.
5 Select the text in the Up State Alpha text box and type 0.

The Up State Alpha text box indicates the level of transparency for the hot spot before the user
clicks it. In your quiz, you're specifying that the hot spot is initially invisible. The Down Alpha
State indicates the level of transparency for the hot spot, once the user clicks it. By accepting
the default setting of 100, you're specifying that the hot spot will display once clicked, which
offers visual feedback to the user.

Arrange text

You'll give the question text the same attributes that you specified in previous frames.

® On the Stage, use the Pointer tool to select the question text. Use the Property inspector to
make the text Arial 14 point bold, with X and Y coordinates of 10.7 and 14. 5, respectively.
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Add a hot spot image
Users click hot spot areas that overlay an image. You'll add that image now.

1 On the Stage, select the instance of Image_Area; the rectangular border that surrounds the hot
spot areas. Refer to the Property inspector to verify that you've selected the correct instance,
and press Backspace or Delete.

———— Image_Area instance

2 With Frame 7 of the Interactions layer selected, drag Camera_top.png from the images folder
of the LearningAssets.fla library, placing it in the approximate center of the Stage.

In the Property inspector, you can specify the X and Y coordinates for the image that the
finished file uses: X= -5.5 and Y=70.8.

3 On the Interactions layer, the image covers the hot spot areas. To change the stacking order of
objects on the layer so that the hot spot areas cover the image instead, verify that
Camera_top.png is still selected, and choose Modify > Arrange > Send to Back.

The hot spot areas now appear over the camera image.
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4 On the Stage, use the Pointer tool to drag HS_Area6 to cover the film advance lever.

5 With the Pointer tool, continue to select and place hot spot areas over the camera, as follows:

® Place the instance of HS_Area3 so that it covers the shutter release.

Note: It does not matter that the Hot Spot area is larger than the shutter release. The size of the Hot Spot areas
will change when you add images to the Hot Spot symbols.

® Place the instance of HS_Area5 so that it covers the shutter speed selector.
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Place the instance of HS_Area4 so that it covers the aperture.

Add an image within a hot spot area

When the user clicks a hot spot area, visual feedback should let the user know that the clicked area is
selected. You'll provide that feedback by adding “glow” images that initially have an alpha

transparency of 0, as specified in the component parameters, but become opaque in the movie upon
mouse click. To add the images, you delete and replace the images within each hot spot movie clip.

1

On the Stage, double-click HS_Areal. In symbol-editing mode, use the Pointer tool to select
the graphics by dragging from above the upper-left corner to below the lower-right corner of
the group, selecting all graphics in the movie clip. Press Backspace or Delete.

From the Images folder of the LearningAssets.fla library, drag rewind_glow.png and place it
within HS_Areal so that the “glow” outlines the film rewinder.

S

Note: The bounding box reflects the new Hot Spot area.
Click Scene 1, above the Stage.

On the Stage, double-click HS_Area2. In symbol-editing mode, use the Pointer tool to drag
around the hot spot graphics, selecting all of the graphics as you did in step 1, then press
Backspace or Delete.

From the Images folder of the LearningAssets.fla library, drag lens_glow.png and place it
within HS_Area2 so that the “glow” outlines the lens, then click Scene 1, above the Stage.
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6 Repeat the previous steps 4 and 5 to open a hot spot in symbol editing mode, delete the
existing group of graphics, then drag and position the corresponding glow image from the
Images folder in the LearningAssets.fla library, as follows (remember to click Scene 1 when
you've finished with a hot spot):

® For HS_Area3, use Shutter_glow.png. Place the glow image around the shutter release button.
® For HS_Area4, use Aperture_glow.png. Place the glow image around the aperture.

® For HS_Area5, use Shutter_speed_glow.png. Place the glow image around the shutter
speed selector.

® For HS_Area6, use Advance_glow.png. Place the glow image around the film advance lever.

Add an interaction to the Timeline

To add an interaction to the Timeline, you add frames across all layers in the Timeline. You can
then either use an interaction from the library, or you can use the streamlined process that you'll
follow now, to copy the interaction from one frame to another.

1 In the Timeline, select Frame 7 in the top layer, the Instructions layer. Hold Shift and select
Frame 7 in all of the layers below the Instructions layer.
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2 Right-click (Windows) or Control-click (Macintosh) a selected frame and choose Insert Frame
from the context menu.

o |ew

The Timeline extends evenly across all layers.

Remaove Frames

Insert Keyframe

Inzert Blank K.eyframe

Clear Keyframe

Convert ko Keyframes
Convert ko Blank Keyframes

Cut Frames

Copy Frames
Faste Frames
Clear Frames
Select All Frames

Heverse Frames
Snehranize Symbo]s

Actions

Propertiez

3 Select Frame 8 of the Interactions layer and choose Insert > Blank Keyframe.

4 Select Frame 3 of the Interactions layer, and choose Edit > Copy Frames.

5 Select Frame 8 of the Interactions layer and choose Edit > Paste Frames.

6 A copy of the Fill in the Blank interaction appears on the Stage. Deselect all selected objects,
then select and delete the camera image and the “glow” image.

Using a Macromedia Flash MX quiz template
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Arrange text and graphics

You'll arrange text and graphics on the Stage, just as you did for the first Fill in the Blank interaction.

1

Verify that Frame 8 of the Interactions layer is still selected. In your MyQuiz library, drag
Cameral.png to the Stage. Place the image below the input text field, as shown in the
following illustration.

Control Button

To the left of the Stage, select the Fill in the Blank component. Launch the Component
Parameters Panel, if necessary.

Select the text in the Question text box and type What mechanism opens to allow light to
enter through the camera lens?

In the first Responses text box, type Shutter, and select the correct check box for the response.
Verify that Case Sensitive is not selected, and Exact Match is selected.

Click Options, along the bottom of the panel and verify that 2 is the Tries text box. Change
the feedback text, as desired.

Modify the quiz results

The last frame in the template displays the quiz results. You can modify text on the quiz results
frame, and add graphics, but you should not change the names of the dynamic text fields or the
results will not appear. Additionally, do not add interactions to the frame containing quiz results.

1

In the Timeline, select Frame 9 of any layer, then use the Pointer tool to select just the Quiz
Results text on the Stage.

Using the Property inspector, make the text 14 point Arial bold, with an X coordinate of 10.7
and a Y coordinate of 14.5.

Select the Line tool. In the Property Inspector, verify that 1 is selected for the stroke height,
and Solid is selected for the stroke style. Hold Shift, while drawing a horizontal line from the

lower edge of the “s” in “Results,” to end just before the edge of the Stage.

In the toolbox, select the Rectangle tool and open the Color Mixer (Windows > Color Mixer),
if necessary.
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5 In the Color Mixer, select Solid as the Fill style. Select the blue stroke color of #0099FE Select
a white fill color of #FFFFFE, with an alpha value of 20%.

 Color Mixer =

| Rl
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L 1=1E3 alpha: [25% ||
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You can either find the color chip with the specified value, or type the hexadecimal value
directly in the text box.

6 Verify that you're on Frame 9 of the Interactions layer. On the Stage, draw a rectangle that
encloses the score.

7 To group the rectangle fill with its stroke, use the Pointer tool to double click inside of the
rectangle and choose Modify > Group.

Total Comect: [0 |

Totalincomect: [1__ |
TotlScore: [0 |

8 In the Align panel (choose Window > Align if the panel is not open), select To Stage, then click
Align Vertical Center and Align Horizontal Center.

Note: All of the assets that you used from the LearningAssets library are now part of your MyQuiz library. You’ve
finished modifying the interactions; this would be a good time to organize your MyQuiz library. For example, you can
create an Images folder for the PNG files.
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Publish the quiz for AICC Tracking

Macromedia Flash quiz templates allow communication with both AICC and SCORM-
compliant learning management systems. Code built into the Macromedia Flash document and
the HTML file created during the publish process send formatted data, including the score and
time spent taking the quiz, to the LMS.

For an overview of the AICC and SCORM communication process, see Using Macromedia
Flash MX learning interactions at http://www.macromedia.com/support/flash/applications/
learning_interactions/.

1 Choose File > Publish Settings.

2 In the Publish Settings dialog box, verify that Flash (.swf) and HTML are selected in the
Formats panel.

3 On the HTML tab of the Publish Settings dialog box, select the Flash w/AICC Tracking
template, then click Publish and close the dialog box.

The publish process creates a Macromedia Flash SWF file and HTML file, which are saved in
the same directory as the FLA file. You can open the MyQuiz.html file in a browser to see how
your quiz appears in a web page.

Other tracking processes

To continue configuring your quiz for AICC tracking, you would complete the following process.

1 Place the Macromedia Flash SWF file and HTML file that you just created on the web server,
with both files in the same directory.

2 Inyour Macromedia Flash MX application folder, browse to First Run/HTML/Learning
Extensions Srvr Files. Within the folder, copy frameset.htm, result.htm, and the scripts sub folder
to the same web server directory where you copied the SWF and HTML files that you published.

3 In a text editor, open the copy of frameset.htm. In the second line of text, change Untitled-1
to the name of your HTML file, which should be MyQuiz.html.

4 Either launch your LMS or create the AICC Course Descriptor Files that reference the
frameset.htm file.

Moving on

To find out more about creating instructional media with Macromedia Flash, visit the
Macromedia Flash Support Center at http://www.macromedia.com/support/flash/.
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